Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: MaxxAir vent problem

MaxxAir vent problem 1 year 7 months ago #1

  • almcc
  • almcc's Avatar
  • NOW OFFLINE
  • Posts: 593
  • Thank You(s): 136
  • Karma: 5
Hi Folks, I'm looking for some suggestions before I start digging into a problem with our Maxxair vent in the living area (above the kitchen area) in our 2013 36RL.

It has the wired remote and the fan comes on but the vent lid doesn't open when I push the button. If I manually open the lid, the unit shuts down normally (lid closes and fan shuts off). When it was working normally, I'd get one beep when it opened and the fan would come on, if the rain sensor detected rain I would get 2 beeps and the lid wouldn't open.

I'm wondering if the rain sensor is bad. I was thinking to start by bypassing the sensor to see if this is the problem.

Comments?

Thanks!

Please Log in or Create an account to join the conversation.

MaxxAir vent problem 1 year 7 months ago #2

x
The following user(s) said Thank You: Iceman1777

Please Log in or Create an account to join the conversation.

Last Edit: by GipCTravelers.
  • Page:
  • 1
Time to create page: 0.217 seconds

 


Redwood Owners Group, Inc. * 5753 Hwy 85 North #3057 * Crestview, FL 32536 

Working together to

share knowledge and fellowship!

ROGLogoClean

 

 

Terms of service

Redwood Owners Group, Inc. is the quintessential Redwood Owners Group providing a website and events for the discussion of technical, practical, and entertaining issues relating to all Redwood Residential Vehicles. These include the Redwood, Sequoia, Cypress and Blackwood lines of residential vehicles.  The Redwood Owners Group provides through rallies, meetups and social networking many ways to meet and connect with other Redwood RV owners.

Redwood Owners Group, Inc. is not affiliated with Redwood or CrossRoads Recreational Vehicles, its subsidiaries, or affiliates.